Inbound Calls Failing

Incident Report for RedRoverIT

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 15:47 CDT

Investigating

We are aware of an issue with inbound calls on our legacy platform. We are working with upstream vendors to locate the issue and reach a resolution.

Thanks!
Posted Apr 14, 2025 - 10:32 CDT
This incident affected: roverVOICE (Inbound & Outbound Call Trunks).